Dare I Say It?

Discussion in 'Chit Chat' started by Mikie, Sep 19, 2012.

  1. Mikie

    Mikie Moderator

    I don't want to jinx things but, all of a sudden, my computer has sped up to warp speed. I didn't do anything to cause it to work better. It's been slooooow for months. I've tried everything but nothing has helped. All of a sudden, something goosed it. I just hope it stays this fast. Fingers crossed. We really need a patron saint of computers. Perhaps Steve Jobs. It might be a stretch to get the church to cannonize him so he might have to be an unofficial saint.

    Wish the same thing which goosed the computer would visit some energy upon me. Who is the patron saint of energy?

    Love, Mikie
  2. Mikie

    Mikie Moderator

    Diane, I went through that with Comcast about six months ago. I don't rent my modem so I got the "new and improved" one they suggested. My old one was older than dust. When I tried to hook up my modem (you have to do it with them on the line) Comcast input the wrong IMAC number so it wouldn't work. After hours messing around, I had to get back on the phone and they finally got things fixed for me. Then, I tried to hook up my not-very-old router but it wouldn't work. So, I went out and bought a "new-and-improved" router which is compatible with the "new-and-improved" modem. I later learned that I probably could have gone online and downloaded new software to install the old router. Geez, I hope you have an easier time than I did. I'm not trying to scare you. I hope my experience helps you. We already have faster speed internet and improved ("new-and-improved") digital TV.

    Leah, Glad kitty doesn't need a new modem. Tweety is already fast enough :) The old saints were cannonized long before we ever had such things. There are new saints being beatified but it doesn't seem to me that they are high tech. Of course, I ask the saints that be to pray for my health but a saint just for energy would be awesome!

    Computer is acting a bit strangely so I don't think it OK yet. For instance, the arrow keys aren't working. Oy! It's always something!

    Happy computing, everyone.

    Love, Mikie